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SRM11102003A: Troubleshooting popup issues

Last Updated: November 25, 2003
 

Problem

Popup messages do not arrive at their destination.
 

Cause

Several causes can contribute to this issue. See the solution section below for more details.
 

Solution

Check your environment for the following configuration issues:
1. On 2003/XP/2000/NT systems, the "Messenger" service has to be running.
2. On 9x/Me systems, WINPOPUP.EXE has to be resident in memory.
3.

Always check the application event log on the computer hosting the SpaceGuard SRM service for error messages. The most common are:

Error 5: Access denied, SpaceGuard SRM service account doesn't have proper rights.
Error 2273: Windows reports that the target user is not logged on to any computer.
Error 53: The Network path could not be found. The name probably contains spaces. Make sure you specified the username (login name), not the full name or display name.
Error 123: The filename, directory name, or volume label syntax is incorrect. If you are using the syntax <domain>\<username>, try the single user target step 6 to see if the NET SEND command can send a popup successfully.

4. Make sure the messenger ports are not being blocked by an internal firewall.
5. Try troubleshooting on multiple operating systems, since there are reports of issues with sending popups using the Windows XP operating system. The best choice for testing popups is Windows 2000.
   
  DISCLAIMER: The troubleshooting tips below rely on using the Microsoft NET SEND command. This command is not written nor supported by Tools4ever. If the NET SEND command does not result in a successful popup message, SpaceGuard SRM will not be able to send popups either. All error messages reported by the NET SEND command are reported by the Windows Operating System, not by SpaceGuard SRM.
   
  Single user target:
6. Using NET SEND <account> "message", the message has to arrive at the destination.
 
A If the NET SEND command fails with error 2273, the target user is not logged on to any computer in the network.
B

SpaceGuard SRM supports 2 methods of sending popups to users: local or domain.

Local: <username>
Domain: <domain>\<username>, this will instruct SpaceGuard SRM to send the popup from the domain controller. When using this syntax, make sure the SpaceGuard SRM service account (default: SpaceGuardSvcAccnt) has at least "Account Operator" priviliges in the domain where the users are located. This syntax has a higher probability of finding the correct user.

   
  Domain group target:
7. Using NET SEND <account> "message", the message has to arrive at the destination. Use a single group member to test this command, as NET SEND doesn't support sending to groups.
 
A If the NET SEND command fails with error 2273, the target user is not logged on to any computer in the network.
B

SpaceGuard SRM supports 2 methods of sending popups to groups: local or domain.

Local: <groupname>, this will instruct SpaceGuard SRM to regard the group as a local group on the machine.
Domain: <domain>\<groupname>, this will instruct SpaceGuard SRM to regard the group as a domain group, and send the popup from the domain controller. When using this syntax, make sure the SpaceGuard SRM service account (default: SpaceGuardSvcAccnt) has at least "Account Operator" priviliges in the domain where the users are located. This syntax has a higher probability of finding the correct user.

   
  Computer target:
8. Using NET SEND <computer> "message", the message has to arrive at the destination.
 
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